87bf792fefc1cca76db21180f84d707d45540dec
[lhc/web/wiklou.git] / includes / installer / i18n / en.json
1 {
2 "@metadata": {
3 "authors": []
4 },
5 "config-desc": "The installer for MediaWiki",
6 "config-title": "MediaWiki $1 installation",
7 "config-information": "Information",
8 "config-localsettings-upgrade": "A <code>LocalSettings.php</code> file has been detected.\nTo upgrade this installation, please enter the value of <code>$wgUpgradeKey</code> in the box below.\nYou will find it in <code>LocalSettings.php</code>.",
9 "config-localsettings-cli-upgrade": "A <code>LocalSettings.php</code> file has been detected.\nTo upgrade this installation, please run <code>update.php</code> instead",
10 "config-localsettings-key": "Upgrade key:",
11 "config-localsettings-badkey": "The upgrade key you provided is incorrect.",
12 "config-upgrade-key-missing": "An existing installation of MediaWiki has been detected.\nTo upgrade this installation, please put the following line at the bottom of your <code>LocalSettings.php</code>:\n\n$1",
13 "config-localsettings-incomplete": "The existing <code>LocalSettings.php</code> appears to be incomplete.\nThe $1 variable is not set.\nPlease change <code>LocalSettings.php</code> so that this variable is set, and click \"{{int:Config-continue}}\".",
14 "config-localsettings-connection-error": "An error was encountered when connecting to the database using the settings specified in <code>LocalSettings.php</code>. Please fix these settings and try again.\n\n$1",
15 "config-session-error": "Error starting session: $1",
16 "config-session-expired": "Your session data seems to have expired.\nSessions are configured for a lifetime of $1.\nYou can increase this by setting <code>session.gc_maxlifetime</code> in php.ini.\nRestart the installation process.",
17 "config-no-session": "Your session data was lost!\nCheck your php.ini and make sure <code>session.save_path</code> is set to an appropriate directory.",
18 "config-your-language": "Your language:",
19 "config-your-language-help": "Select a language to use during the installation process.",
20 "config-wiki-language": "Wiki language:",
21 "config-wiki-language-help": "Select the language that the wiki will predominantly be written in.",
22 "config-back": "← Back",
23 "config-continue": "Continue →",
24 "config-page-language": "Language",
25 "config-page-welcome": "Welcome to MediaWiki!",
26 "config-page-dbconnect": "Connect to database",
27 "config-page-upgrade": "Upgrade existing installation",
28 "config-page-dbsettings": "Database settings",
29 "config-page-name": "Name",
30 "config-page-options": "Options",
31 "config-page-install": "Install",
32 "config-page-complete": "Complete!",
33 "config-page-restart": "Restart installation",
34 "config-page-readme": "Read me",
35 "config-page-releasenotes": "Release notes",
36 "config-page-copying": "Copying",
37 "config-page-upgradedoc": "Upgrading",
38 "config-page-existingwiki": "Existing wiki",
39 "config-help-restart": "Do you want to clear all saved data that you have entered and restart the installation process?",
40 "config-restart": "Yes, restart it",
41 "config-welcome": "=== Environmental checks ===\nBasic checks will now be performed to see if this environment is suitable for MediaWiki installation.\nRemember to include this information if you seek support on how to complete the installation.",
42 "config-copyright": "=== Copyright and Terms ===\n\n$1\n\nThis program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.\n\nThis program is distributed in the hope that it will be useful, but <strong>without any warranty</strong>; without even the implied warranty of <strong>merchantability</strong> or <strong>fitness for a particular purpose</strong>.\nSee the GNU General Public License for more details.\n\nYou should have received <doclink href=Copying>a copy of the GNU General Public License</doclink> along with this program; if not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA, or [https://www.gnu.org/copyleft/gpl.html read it online].",
43 "config-sidebar": "* [https://www.mediawiki.org MediaWiki home]\n* [https://www.mediawiki.org/wiki/Special:MyLanguage/Help:Contents User's Guide]\n* [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:Contents Administrator's Guide]\n* [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:FAQ FAQ]\n----\n* <doclink href=Readme>Read me</doclink>\n* <doclink href=ReleaseNotes>Release notes</doclink>\n* <doclink href=Copying>Copying</doclink>\n* <doclink href=UpgradeDoc>Upgrading</doclink>",
44 "config-env-good": "The environment has been checked.\nYou can install MediaWiki.",
45 "config-env-bad": "The environment has been checked.\nYou cannot install MediaWiki.",
46 "config-env-php": "PHP $1 is installed.",
47 "config-env-hhvm": "HHVM $1 is installed.",
48 "config-unicode-using-intl": "Using the [https://pecl.php.net/intl intl PECL extension] for Unicode normalization.",
49 "config-unicode-pure-php-warning": "<strong>Warning:</strong> The [https://pecl.php.net/intl intl PECL extension] is not available to handle Unicode normalization, falling back to slow pure-PHP implementation.\nIf you run a high-traffic site, you should read a little on [https://www.mediawiki.org/wiki/Special:MyLanguage/Unicode_normalization_considerations Unicode normalization].",
50 "config-unicode-update-warning": "<strong>Warning:</strong> The installed version of the Unicode normalization wrapper uses an older version of [http://site.icu-project.org/ the ICU project's] library.\nYou should [https://www.mediawiki.org/wiki/Special:MyLanguage/Unicode_normalization_considerations upgrade] if you are at all concerned about using Unicode.",
51 "config-no-db": "Could not find a suitable database driver! You need to install a database driver for PHP.\nThe following database {{PLURAL:$2|type is|types are}} supported: $1.\n\nIf you compiled PHP yourself, reconfigure it with a database client enabled, for example, using <code>./configure --with-mysqli</code>.\nIf you installed PHP from a Debian or Ubuntu package, then you also need to install, for example, the <code>php-mysql</code> package.",
52 "config-outdated-sqlite": "<strong>Warning:</strong> you have SQLite $1, which is lower than minimum required version $2. SQLite will be unavailable.",
53 "config-no-fts3": "<strong>Warning:</strong> SQLite is compiled without the [//sqlite.org/fts3.html FTS3 module], search features will be unavailable on this backend.",
54 "config-pcre-old": "<strong>Fatal:</strong> PCRE $1 or later is required.\nYour PHP binary is linked with PCRE $2.\n[https://www.mediawiki.org/wiki/Manual:Errors_and_symptoms/PCRE More information].",
55 "config-pcre-no-utf8": "<strong>Fatal:</strong> PHP's PCRE module seems to be compiled without PCRE_UTF8 support.\nMediaWiki requires UTF-8 support to function correctly.",
56 "config-memory-raised": "PHP's <code>memory_limit</code> is $1, raised to $2.",
57 "config-memory-bad": "<strong>Warning:</strong> PHP's <code>memory_limit</code> is $1.\nThis is probably too low.\nThe installation may fail!",
58 "config-apc": "[https://secure.php.net/apc APC] is installed",
59 "config-apcu": "[https://secure.php.net/apcu APCu] is installed",
60 "config-wincache": "[https://www.iis.net/downloads/microsoft/wincache-extension WinCache] is installed",
61 "config-no-cache-apcu": "<strong>Warning:</strong> Could not find [https://secure.php.net/apcu APCu] or [https://www.iis.net/downloads/microsoft/wincache-extension WinCache].\nObject caching is not enabled.",
62 "config-mod-security": "<strong>Warning:</strong> Your web server has [https://modsecurity.org/ mod_security]/mod_security2 enabled. Many common configurations of this will cause problems for MediaWiki and other software that allows users to post arbitrary content.\nIf possible, this should be disabled. Otherwise, refer to [https://modsecurity.org/documentation/ mod_security documentation] or contact your host's support if you encounter random errors.",
63
64 "config-diff3-bad": "GNU diff3 not found.",
65 "config-git": "Found the Git version control software: <code>$1</code>.",
66 "config-git-bad": "Git version control software not found.",
67 "config-imagemagick": "Found ImageMagick: <code>$1</code>.\nImage thumbnailing will be enabled if you enable uploads.",
68 "config-gd": "Found GD graphics library built-in.\nImage thumbnailing will be enabled if you enable uploads.",
69 "config-no-scaling": "Could not find GD library or ImageMagick.\nImage thumbnailing will be disabled.",
70 "config-no-uri": "<strong>Error:</strong> Could not determine the current URI.\nInstallation aborted.",
71 "config-no-cli-uri": "<strong>Warning:</strong> No <code>--scriptpath</code> specified, using default: <code>$1</code>.",
72 "config-using-server": "Using server name \"<nowiki>$1</nowiki>\".",
73 "config-using-uri": "Using server URL \"<nowiki>$1$2</nowiki>\".",
74 "config-uploads-not-safe": "<strong>Warning:</strong> Your default directory for uploads <code>$1</code> is vulnerable to arbitrary scripts execution.\nAlthough MediaWiki checks all uploaded files for security threats, it is highly recommended to [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:Security#Upload_security close this security vulnerability] before enabling uploads.",
75 "config-no-cli-uploads-check": "<strong>Warning:</strong> Your default directory for uploads (<code>$1</code>) is not checked for vulnerability\nto arbitrary script execution during the CLI install.",
76 "config-brokenlibxml": "Your system has a combination of PHP and libxml2 versions that is buggy and can cause hidden data corruption in MediaWiki and other web applications.\nUpgrade to libxml2 2.7.3 or later ([https://bugs.php.net/bug.php?id=45996 bug filed with PHP]).\nInstallation aborted.",
77 "config-suhosin-max-value-length": "Suhosin is installed and limits the GET parameter <code>length</code> to $1 bytes.\nMediaWiki's ResourceLoader component will work around this limit, but that will degrade performance.\nIf at all possible, you should set <code>suhosin.get.max_value_length</code> to 1024 or higher in <code>php.ini</code>, and set <code>$wgResourceLoaderMaxQueryLength</code> to the same value in <code>LocalSettings.php</code>.",
78 "config-using-32bit": "<strong>Warning:</strong> your system appears to be running with 32-bit integers. This is [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:32-bit not advised].",
79 "config-db-type": "Database type:",
80 "config-db-host": "Database host:",
81 "config-db-host-help": "If your database server is on different server, enter the host name or IP address here.\n\nIf you are using shared web hosting, your hosting provider should give you the correct host name in their documentation.\n\nIf you are installing on a Windows server and using MySQL, using \"localhost\" may not work for the server name. If it does not, try \"127.0.0.1\" for the local IP address.\n\nIf you are using PostgreSQL, leave this field blank to connect via a Unix socket.",
82 "config-db-host-oracle": "Database TNS:",
83 "config-db-host-oracle-help": "Enter a valid [http://download.oracle.com/docs/cd/B28359_01/network.111/b28317/tnsnames.htm Local Connect Name]; a tnsnames.ora file must be visible to this installation.<br />If you are using client libraries 10g or newer you can also use the [http://download.oracle.com/docs/cd/E11882_01/network.112/e10836/naming.htm Easy Connect] naming method.",
84 "config-db-wiki-settings": "Identify this wiki",
85 "config-db-name": "Database name:",
86 "config-db-name-help": "Choose a name that identifies your wiki.\nIt should not contain spaces.\n\nIf you are using shared web hosting, your hosting provider will either give you a specific database name to use or let you create databases via a control panel.",
87 "config-db-name-oracle": "Database schema:",
88 "config-db-account-oracle-warn": "There are three supported scenarios for installing Oracle as database backend:\n\nIf you wish to create database account as part of the installation process, please supply an account with SYSDBA role as database account for installation and specify the desired credentials for the web-access account, otherwise you can either create the web-access account manually and supply only that account (if it has required permissions to create the schema objects) or supply two different accounts, one with create privileges and a restricted one for web access.\n\nScript for creating an account with required privileges can be found in \"maintenance/oracle/\" directory of this installation. Keep in mind that using a restricted account will disable all maintenance capabilities with the default account.",
89 "config-db-install-account": "User account for installation",
90 "config-db-username": "Database username:",
91 "config-db-password": "Database password:",
92 "config-db-install-username": "Enter the username that will be used to connect to the database during the installation process.\nThis is not the username of the MediaWiki account; this is the username for your database.",
93 "config-db-install-password": "Enter the password that will be used to connect to the database during the installation process.\nThis is not the password for the MediaWiki account; this is the password for your database.",
94 "config-db-install-help": "Enter the username and password that will be used to connect to the database during the installation process.",
95 "config-db-account-lock": "Use the same username and password during normal operation",
96 "config-db-wiki-account": "User account for normal operation",
97 "config-db-wiki-help": "Enter the username and password that will be used to connect to the database during normal wiki operation.\nIf the account does not exist, and the installation account has sufficient privileges, this user account will be created with the minimum privileges required to operate the wiki.",
98 "config-db-prefix": "Database table prefix:",
99 "config-db-prefix-help": "If you need to share one database between multiple wikis, or between MediaWiki and another web application, you may choose to add a prefix to all the table names to avoid conflicts.\nDo not use spaces.\n\nThis field is usually left empty.",
100 "config-mysql-old": "MySQL $1 or later is required. You have $2.",
101 "config-db-port": "Database port:",
102 "config-db-schema": "Schema for MediaWiki:",
103 "config-db-schema-help": "This schema will usually be fine.\nOnly change it if you know you need to.",
104 "config-pg-test-error": "Cannot connect to database <strong>$1</strong>: $2",
105 "config-sqlite-dir": "SQLite data directory:",
106 "config-sqlite-dir-help": "SQLite stores all data in a single file.\n\nThe directory you provide must be writable by the webserver during installation.\n\nIt should <strong>not</strong> be accessible via the web; this is why we're not putting it where your PHP files are.\n\nThe installer will write a <code>.htaccess</code> file along with it, but if that fails someone can gain access to your raw database.\nThat includes raw user data (email addresses, hashed passwords) as well as deleted revisions and other restricted data on the wiki.\n\nConsider putting the database somewhere else altogether, for example in <code>/var/lib/mediawiki/yourwiki</code>.",
107 "config-oracle-def-ts": "Default tablespace:",
108 "config-oracle-temp-ts": "Temporary tablespace:",
109 "config-type-mysql": "MariaDB, MySQL, or compatible",
110 "config-type-postgres": "PostgreSQL",
111 "config-type-sqlite": "SQLite",
112 "config-type-oracle": "Oracle",
113 "config-type-mssql": "Microsoft SQL Server",
114 "config-support-info": "MediaWiki supports the following database systems:\n\n$1\n\nIf you do not see the database system you are trying to use listed below, then follow the instructions linked above to enable support.",
115 "config-dbsupport-mysql": "* [{{int:version-db-mariadb-url}} MariaDB] is the primary target for MediaWiki and is best supported. MediaWiki also works with [{{int:version-db-mysql-url}} MySQL] and [{{int:version-db-percona-url}} Percona Server], which are MariaDB compatible. ([https://secure.php.net/manual/en/mysqli.installation.php How to compile PHP with MySQL support])",
116 "config-dbsupport-postgres": "* [{{int:version-db-postgres-url}} PostgreSQL] is a popular open source database system as an alternative to MySQL. ([https://secure.php.net/manual/en/pgsql.installation.php How to compile PHP with PostgreSQL support])",
117 "config-dbsupport-sqlite": "* [{{int:version-db-sqlite-url}} SQLite] is a lightweight database system that is very well supported. ([https://secure.php.net/manual/en/pdo.installation.php How to compile PHP with SQLite support], uses PDO)",
118 "config-dbsupport-oracle": "* [{{int:version-db-oracle-url}} Oracle] is a commercial enterprise database. ([https://secure.php.net/manual/en/oci8.installation.php How to compile PHP with OCI8 support])",
119 "config-dbsupport-mssql": "* [{{int:version-db-mssql-url}} Microsoft SQL Server] is a commercial enterprise database for Windows. ([https://secure.php.net/manual/en/sqlsrv.installation.php How to compile PHP with SQLSRV support])",
120 "config-header-mysql": "MariaDB/MySQL settings",
121 "config-header-postgres": "PostgreSQL settings",
122 "config-header-sqlite": "SQLite settings",
123 "config-header-oracle": "Oracle settings",
124 "config-header-mssql": "Microsoft SQL Server settings",
125 "config-invalid-db-type": "Invalid database type.",
126 "config-missing-db-name": "You must enter a value for \"{{int:config-db-name}}\".",
127 "config-missing-db-host": "You must enter a value for \"{{int:config-db-host}}\".",
128 "config-missing-db-server-oracle": "You must enter a value for \"{{int:config-db-host-oracle}}\".",
129 "config-invalid-db-server-oracle": "Invalid database TNS \"$1\".\nUse either \"TNS Name\" or an \"Easy Connect\" string ([http://docs.oracle.com/cd/E11882_01/network.112/e10836/naming.htm Oracle Naming Methods]).",
130 "config-invalid-db-name": "Invalid database name \"$1\".\nUse only ASCII letters (a-z, A-Z), numbers (0-9), underscores (_) and hyphens (-).",
131 "config-invalid-db-prefix": "Invalid database prefix \"$1\".\nUse only ASCII letters (a-z, A-Z), numbers (0-9), underscores (_) and hyphens (-).",
132 "config-connection-error": "$1.\n\nCheck the host, username and password and try again.",
133 "config-invalid-schema": "Invalid schema for MediaWiki \"$1\".\nUse only ASCII letters (a-z, A-Z), numbers (0-9) and underscores (_).",
134 "config-db-sys-create-oracle": "Installer only supports using a SYSDBA account for creating a new account.",
135 "config-db-sys-user-exists-oracle": "User account \"$1\" already exists. SYSDBA can only be used for creating of a new account!",
136 "config-postgres-old": "PostgreSQL $1 or later is required. You have $2.",
137 "config-mssql-old": "Microsoft SQL Server $1 or later is required. You have $2.",
138 "config-sqlite-name-help": "Choose a name that identifies your wiki.\nDo not use spaces or hyphens.\nThis will be used for the SQLite data filename.",
139 "config-sqlite-parent-unwritable-group": "Cannot create the data directory <code><nowiki>$1</nowiki></code>, because the parent directory <code><nowiki>$2</nowiki></code> is not writable by the webserver.\n\nThe installer has determined the user your webserver is running as.\nMake the <code><nowiki>$3</nowiki></code> directory writable by it to continue.\nOn a Unix/Linux system do:\n\n<pre>cd $2\nmkdir $3\nchgrp $4 $3\nchmod g+w $3</pre>",
140 "config-sqlite-parent-unwritable-nogroup": "Cannot create the data directory <code><nowiki>$1</nowiki></code>, because the parent directory <code><nowiki>$2</nowiki></code> is not writable by the webserver.\n\nThe installer could not determine the user your webserver is running as.\nMake the <code><nowiki>$3</nowiki></code> directory globally writable by it (and others!) to continue.\nOn a Unix/Linux system do:\n\n<pre>cd $2\nmkdir $3\nchmod a+w $3</pre>",
141 "config-sqlite-mkdir-error": "Error creating the data directory \"$1\".\nCheck the location and try again.",
142 "config-sqlite-dir-unwritable": "Unable to write to the directory \"$1\".\nChange its permissions so that the webserver can write to it, and try again.",
143 "config-sqlite-connection-error": "$1.\n\nCheck the data directory and database name below and try again.",
144 "config-sqlite-readonly": "The file <code>$1</code> is not writeable.",
145 "config-sqlite-cant-create-db": "Could not create database file <code>$1</code>.",
146 "config-sqlite-fts3-downgrade": "PHP is missing FTS3 support, downgrading tables.",
147 "config-can-upgrade": "There are MediaWiki tables in this database.\nTo upgrade them to MediaWiki $1, click <strong>Continue</strong>.",
148 "config-upgrade-done": "Upgrade complete.\n\nYou can now [$1 start using your wiki].\n\nIf you want to regenerate your <code>LocalSettings.php</code> file, click the button below.\nThis is <strong>not recommended</strong> unless you are having problems with your wiki.",
149 "config-upgrade-done-no-regenerate": "Upgrade complete.\n\nYou can now [$1 start using your wiki].",
150 "config-regenerate": "Regenerate LocalSettings.php →",
151 "config-show-table-status": "<code>SHOW TABLE STATUS</code> query failed!",
152 "config-unknown-collation": "<strong>Warning:</strong> Database is using unrecognized collation.",
153 "config-db-web-account": "Database account for web access",
154 "config-db-web-help": "Select the username and password that the web server will use to connect to the database server, during ordinary operation of the wiki.",
155 "config-db-web-account-same": "Use the same account as for installation",
156 "config-db-web-create": "Create the account if it does not already exist",
157 "config-db-web-no-create-privs": "The account you specified for installation does not have enough privileges to create an account.\nThe account you specify here must already exist.",
158 "config-mysql-engine": "Storage engine:",
159 "config-mysql-innodb": "InnoDB (recommended)",
160 "config-mysql-myisam": "MyISAM",
161 "config-mysql-myisam-dep": "<strong>Warning:</strong> You have selected MyISAM as storage engine for MySQL, which is not recommended for use with MediaWiki, because:\n* it barely supports concurrency due to table locking\n* it is more prone to corruption than other engines\n* the MediaWiki codebase does not always handle MyISAM as it should\n\nIf your MySQL installation supports InnoDB, it is highly recommended that you choose that instead.\nIf your MySQL installation does not support InnoDB, maybe it's time for an upgrade.",
162 "config-mysql-only-myisam-dep": "<strong>Warning:</strong> MyISAM is the only available storage engine for MySQL on this machine, and this is not recommended for use with MediaWiki, because:\n* it barely supports concurrency due to table locking\n* it is more prone to corruption than other engines\n* the MediaWiki codebase does not always handle MyISAM as it should\n\nYour MySQL installation does not support InnoDB, maybe it's time for an upgrade.",
163 "config-mysql-engine-help": "<strong>InnoDB</strong> is almost always the best option, since it has good concurrency support.\n\n<strong>MyISAM</strong> may be faster in single-user or read-only installations.\nMyISAM databases tend to get corrupted more often than InnoDB databases.",
164 "config-mssql-auth": "Authentication type:",
165 "config-mssql-install-auth": "Select the authentication type that will be used to connect to the database during the installation process.\nIf you select \"{{int:config-mssql-windowsauth}}\", the credentials of whatever user the webserver is running as will be used.",
166 "config-mssql-web-auth": "Select the authentication type that the web server will use to connect to the database server, during ordinary operation of the wiki.\nIf you select \"{{int:config-mssql-windowsauth}}\", the credentials of whatever user the webserver is running as will be used.",
167 "config-mssql-sqlauth": "SQL Server Authentication",
168 "config-mssql-windowsauth": "Windows Authentication",
169 "config-site-name": "Name of wiki:",
170 "config-site-name-help": "This will appear in the title bar of the browser and in various other places.",
171 "config-site-name-blank": "Enter a site name.",
172 "config-project-namespace": "Project namespace:",
173 "config-ns-generic": "Project",
174 "config-ns-site-name": "Same as the wiki name: $1",
175 "config-ns-other": "Other (specify)",
176 "config-ns-other-default": "MyWiki",
177 "config-project-namespace-help": "Following Wikipedia's example, many wikis keep their policy pages separate from their content pages, in a '''project namespace'''.\nAll page titles in this namespace start with a certain prefix, which you can specify here.\nUsually, this prefix is derived from the name of the wiki, but it cannot contain punctuation characters such as \"#\" or \":\".",
178 "config-ns-invalid": "The specified namespace \"<nowiki>$1</nowiki>\" is invalid.\nSpecify a different project namespace.",
179 "config-ns-conflict": "The specified namespace \"<nowiki>$1</nowiki>\" conflicts with a default MediaWiki namespace.\nSpecify a different project namespace.",
180 "config-admin-box": "Administrator account",
181 "config-admin-name": "Your username:",
182 "config-admin-password": "Password:",
183 "config-admin-password-confirm": "Password again:",
184 "config-admin-help": "Enter your preferred username here, for example \"Joe Bloggs\".\nThis is the name you will use to log in to the wiki.",
185 "config-admin-name-blank": "Enter an administrator username.",
186 "config-admin-name-invalid": "The specified username \"<nowiki>$1</nowiki>\" is invalid.\nSpecify a different username.",
187 "config-admin-password-blank": "Enter a password for the administrator account.",
188 "config-admin-password-mismatch": "The two passwords you entered do not match.",
189 "config-admin-email": "Email address:",
190 "config-admin-email-help": "Enter an email address here to allow you to receive email from other users on the wiki, reset your password, and be notified of changes to pages on your watchlist. You can leave this field empty.",
191 "config-admin-error-user": "Internal error when creating an admin with the name \"<nowiki>$1</nowiki>\".",
192 "config-admin-error-password": "Internal error when setting a password for the admin \"<nowiki>$1</nowiki>\": <pre>$2</pre>",
193 "config-admin-error-bademail": "You have entered an invalid email address.",
194 "config-subscribe": "Subscribe to the [https://lists.wikimedia.org/mailman/listinfo/mediawiki-announce release announcements mailing list].",
195 "config-subscribe-help": "This is a low-volume mailing list used for release announcements, including important security announcements.\nYou should subscribe to it and update your MediaWiki installation when new versions come out.",
196 "config-subscribe-noemail": "You tried to subscribe to the release announcements mailing list without providing an email address.\nPlease provide an email address if you wish to subscribe to the mailing list.",
197 "config-pingback": "Share data about this installation with MediaWiki developers.",
198 "config-pingback-help": "If you select this option, MediaWiki will periodically ping https://www.mediawiki.org with basic data about this MediaWiki instance. This data includes, for example, the type of system, PHP version, and chosen database backend. The Wikimedia Foundation shares this data with MediaWiki developers to help guide future development efforts. The following data will be sent for your system:\n<pre>$1</pre>",
199 "config-almost-done": "You are almost done!\nYou can now skip the remaining configuration and install the wiki right now.",
200 "config-optional-continue": "Ask me more questions.",
201 "config-optional-skip": "I'm bored already, just install the wiki.",
202 "config-profile": "User rights profile:",
203 "config-profile-wiki": "Open wiki",
204 "config-profile-no-anon": "Account creation required",
205 "config-profile-fishbowl": "Authorized editors only",
206 "config-profile-private": "Private wiki",
207 "config-profile-help": "Wikis work best when you let as many people edit them as possible.\nIn MediaWiki, it is easy to review the recent changes, and to revert any damage that is done by naive or malicious users.\n\nHowever, many have found MediaWiki to be useful in a wide variety of roles, and sometimes it is not easy to convince everyone of the benefits of the wiki way.\nSo you have the choice.\n\nThe <strong>{{int:config-profile-wiki}}</strong> model allows anyone to edit, without even logging in.\nA wiki with <strong>{{int:config-profile-no-anon}}</strong> provides extra accountability, but may deter casual contributors.\n\nThe <strong>{{int:config-profile-fishbowl}}</strong> scenario allows approved users to edit, but the public can view the pages, including history.\nA <strong>{{int:config-profile-private}}</strong> only allows approved users to view pages, with the same group allowed to edit.\n\nMore complex user rights configurations are available after installation, see the [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:User_rights relevant manual entry].",
208 "config-license": "Copyright and license:",
209 "config-license-none": "No license footer",
210 "config-license-cc-by-sa": "Creative Commons Attribution-ShareAlike",
211 "config-license-cc-by": "Creative Commons Attribution",
212 "config-license-cc-by-nc-sa": "Creative Commons Attribution-NonCommercial-ShareAlike",
213 "config-license-cc-0": "Creative Commons Zero (Public Domain)",
214 "config-license-gfdl": "GNU Free Documentation License 1.3 or later",
215 "config-license-pd": "Public Domain",
216 "config-license-cc-choose": "Select a custom Creative Commons license",
217 "config-license-help": "Many public wikis put all contributions under a [https://freedomdefined.org/Definition free license].\nThis helps to create a sense of community ownership and encourages long-term contribution.\nIt is not generally necessary for a private or corporate wiki.\n\nIf you want to be able to use text from Wikipedia, and you want Wikipedia to be able to accept text copied from your wiki, you should choose <strong>{{int:config-license-cc-by-sa}}</strong>.\n\nWikipedia previously used the GNU Free Documentation License.\nThe GFDL is a valid license, but it is difficult to understand.\nIt is also difficult to reuse content licensed under the GFDL.",
218 "config-email-settings": "Email settings",
219 "config-enable-email": "Enable outbound email",
220 "config-enable-email-help": "If you want email to work, [https://secure.php.net/manual/en/mail.configuration.php PHP's mail settings] need to be configured correctly.\nIf you do not want any email features, you can disable them here.",
221 "config-email-user": "Enable user-to-user email",
222 "config-email-user-help": "Allow all users to send each other email if they have enabled it in their preferences.",
223 "config-email-usertalk": "Enable user talk page notification",
224 "config-email-usertalk-help": "Allow users to receive notifications on user talk page changes, if they have enabled it in their preferences.",
225 "config-email-watchlist": "Enable watchlist notification",
226 "config-email-watchlist-help": "Allow users to receive notifications about their watched pages if they have enabled it in their preferences.",
227 "config-email-auth": "Enable email authentication",
228 "config-email-auth-help": "If this option is enabled, users have to confirm their email address using a link sent to them whenever they set or change it.\nOnly authenticated email addresses can receive emails from other users or change notification emails.\nSetting this option is <strong>recommended</strong> for public wikis because of potential abuse of the email features.",
229 "config-email-sender": "Return email address:",
230 "config-email-sender-help": "Enter the email address to use as the return address on outbound email.\nThis is where bounces will be sent.\nMany mail servers require at least the domain name part to be valid.",
231 "config-upload-settings": "Images and file uploads",
232 "config-upload-enable": "Enable file uploads",
233 "config-upload-help": "File uploads potentially expose your server to security risks.\nFor more information, read the [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:Security security section] in the manual.\n\nTo enable file uploads, change the mode on the <code>images</code> subdirectory under MediaWiki's root directory so that the web server can write to it.\nThen enable this option.",
234 "config-upload-deleted": "Directory for deleted files:",
235 "config-upload-deleted-help": "Choose a directory in which to archive deleted files.\nIdeally, this should not be accessible from the web.",
236 "config-logo": "Logo URL:",
237 "config-logo-help": "MediaWiki's default skin includes space for a 135x160 pixel logo above the sidebar menu.\nUpload an image of the appropriate size, and enter the URL here.\n\nYou can use <code>$wgStylePath</code> or <code>$wgScriptPath</code> if your logo is relative to those paths.\n\nIf you do not want a logo, leave this box blank.",
238 "config-instantcommons": "Enable Instant Commons",
239 "config-instantcommons-help": "[https://www.mediawiki.org/wiki/InstantCommons Instant Commons] is a feature that allows wikis to use images, sounds and other media found on the [https://commons.wikimedia.org/ Wikimedia Commons] site.\nIn order to do this, MediaWiki requires access to the Internet.\n\nFor more information on this feature, including instructions on how to set it up for wikis other than the Wikimedia Commons, consult [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:$wgForeignFileRepos the manual].",
240 "config-cc-error": "The Creative Commons license chooser gave no result.\nEnter the license name manually.",
241 "config-cc-again": "Pick again...",
242 "config-cc-not-chosen": "Choose which Creative Commons license you want and click \"proceed\".",
243 "config-advanced-settings": "Advanced configuration",
244 "config-cache-options": "Settings for object caching:",
245 "config-cache-help": "Object caching is used to improve the speed of MediaWiki by caching frequently used data.\nMedium to large sites are highly encouraged to enable this, and small sites will see benefits as well.",
246 "config-cache-none": "No caching (no functionality is removed, but speed may be impacted on larger wiki sites)",
247 "config-cache-accel": "PHP object caching (APC, APCu or WinCache)",
248 "config-cache-memcached": "Use Memcached (requires additional setup and configuration)",
249 "config-memcached-servers": "Memcached servers:",
250 "config-memcached-help": "List of IP addresses to use for Memcached.\nShould specify one per line and specify the port to be used. For example:\n 127.0.0.1:11211\n 192.168.1.25:1234",
251 "config-memcache-needservers": "You selected Memcached as your cache type but did not specify any servers.",
252 "config-memcache-badip": "You have entered an invalid IP address for Memcached: $1.",
253 "config-memcache-noport": "You did not specify a port to use for Memcached server: $1.\nIf you do not know the port, the default is 11211.",
254 "config-memcache-badport": "Memcached port numbers should be between $1 and $2.",
255 "config-extensions": "Extensions",
256 "config-extensions-help": "The extensions listed above were detected in your <code>./extensions</code> directory.\n\nThey may require additional configuration, but you can enable them now.",
257 "config-skins": "Skins",
258 "config-skins-help": "The skins listed above were detected in your <code>./skins</code> directory. You must enable at least one, and choose the default.",
259 "config-skins-use-as-default": "Use this skin as default",
260 "config-skins-missing": "No skins were found; MediaWiki will use a fallback skin until you install some proper ones.",
261 "config-skins-must-enable-some": "You must choose at least one skin to enable.",
262 "config-skins-must-enable-default": "The skin chosen as default must be enabled.",
263 "config-install-alreadydone": "<strong>Warning:</strong> You seem to have already installed MediaWiki and are trying to install it again.\nPlease proceed to the next page.",
264 "config-install-begin": "By pressing \"{{int:config-continue}}\", you will begin the installation of MediaWiki.\nIf you still want to make changes, press \"{{int:config-back}}\".",
265 "config-install-step-done": "done",
266 "config-install-step-failed": "failed",
267 "config-install-extensions": "Including extensions",
268 "config-install-database": "Setting up database",
269 "config-install-schema": "Creating schema",
270 "config-install-pg-schema-not-exist": "PostgreSQL schema does not exist.",
271 "config-install-pg-schema-failed": "Tables creation failed.\nMake sure that the user \"$1\" can write to the schema \"$2\".",
272 "config-install-pg-commit": "Committing changes",
273 "config-install-pg-plpgsql": "Checking for language PL/pgSQL",
274 "config-pg-no-plpgsql": "You need to install the language PL/pgSQL in the database $1",
275 "config-pg-no-create-privs": "The account you specified for installation does not have enough privileges to create an account.",
276 "config-pg-not-in-role": "The account you specified for the web user already exists.\nThe account you specified for installation is not a superuser and is not a member of the web user's role, so it is unable to create objects owned by the web user.\n\nMediaWiki currently requires that the tables be owned by the web user. Please specify another web account name, or click \"back\" and specify a suitably privileged install user.",
277 "config-install-user": "Creating database user",
278 "config-install-user-alreadyexists": "User \"$1\" already exists",
279 "config-install-user-create-failed": "Creating user \"$1\" failed: $2",
280 "config-install-user-grant-failed": "Granting permission to user \"$1\" failed: $2",
281 "config-install-user-missing": "The specified user \"$1\" does not exist.",
282 "config-install-user-missing-create": "The specified user \"$1\" does not exist.\nPlease click the \"create account\" checkbox below if you want to create it.",
283 "config-install-tables": "Creating tables",
284 "config-install-tables-exist": "<strong>Warning:</strong> MediaWiki tables seem to already exist.\nSkipping creation.",
285 "config-install-tables-failed": "<strong>Error:</strong> Table creation failed with the following error: $1",
286 "config-install-interwiki": "Populating default interwiki table",
287 "config-install-interwiki-list": "Could not read file <code>interwiki.list</code>.",
288 "config-install-interwiki-exists": "<strong>Warning:</strong> The interwiki table seems to already have entries.\nSkipping default list.",
289 "config-install-stats": "Initializing statistics",
290 "config-install-keys": "Generating secret keys",
291 "config-install-updates": "Prevent running unneeded updates",
292 "config-install-updates-failed": "<strong>Error:</strong> Inserting update keys into tables failed with the following error: $1",
293 "config-install-sysop": "Creating administrator user account",
294 "config-install-subscribe-fail": "Unable to subscribe to mediawiki-announce: $1",
295 "config-install-subscribe-notpossible": "cURL is not installed and <code>allow_url_fopen</code> is not available.",
296 "config-install-mainpage": "Creating main page with default content",
297 "config-install-mainpage-exists": "Main page already exists, skipping",
298 "config-install-extension-tables": "Creating tables for enabled extensions",
299 "config-install-mainpage-failed": "Could not insert main page: $1",
300 "config-install-done": "<strong>Congratulations!</strong>\nYou have installed MediaWiki.\n\nThe installer has generated a <code>LocalSettings.php</code> file.\nIt contains all your configuration.\n\nYou will need to download it and put it in the base of your wiki installation (the same directory as index.php). The download should have started automatically.\n\nIf the download was not offered, or if you cancelled it, you can restart the download by clicking the link below:\n\n$3\n\n<strong>Note:</strong> If you do not do this now, this generated configuration file will not be available to you later if you exit the installation without downloading it.\n\nWhen that has been done, you can <strong>[$2 enter your wiki]</strong>.",
301 "config-install-done-path": "<strong>Congratulations!</strong>\nYou have installed MediaWiki.\n\nThe installer has generated a <code>LocalSettings.php</code> file.\nIt contains all your configuration.\n\nYou will need to download it and put it at <code>$4</code>. The download should have started automatically.\n\nIf the download was not offered, or if you cancelled it, you can restart the download by clicking the link below:\n\n$3\n\n<strong>Note:</strong> If you do not do this now, this generated configuration file will not be available to you later if you exit the installation without downloading it.\n\nWhen that has been done, you can <strong>[$2 enter your wiki]</strong>.",
302 "config-install-success": "MediaWiki has been successfully installed. You can now\nvisit <$1$2> to view your wiki.\nIf you have questions, check out our frequently asked questions list:\n<https://www.mediawiki.org/wiki/Manual:FAQ> or use one of the\nsupport forums linked on that page.",
303 "config-download-localsettings": "Download <code>LocalSettings.php</code>",
304 "config-help": "help",
305 "config-help-tooltip": "click to expand",
306 "config-nofile": "File \"$1\" could not be found. Has it been deleted?",
307 "config-extension-link": "Did you know that your wiki supports [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:Extensions extensions]?\n\nYou can browse [https://www.mediawiki.org/wiki/Special:MyLanguage/Category:Extensions_by_category extensions by category] or the [https://www.mediawiki.org/wiki/Extension_Matrix Extension Matrix] to see the full list of extensions.",
308 "config-skins-screenshots": "$1 (screenshots: $2)",
309 "config-skins-screenshot": "$1 ($2)",
310 "config-extensions-requires": "$1 (requires $2)",
311 "config-screenshot": "screenshot",
312 "mainpagetext": "<strong>MediaWiki has been installed.</strong>",
313 "mainpagedocfooter": "Consult the [https://www.mediawiki.org/wiki/Special:MyLanguage/Help:Contents User's Guide] for information on using the wiki software.\n\n== Getting started ==\n* [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:Configuration_settings Configuration settings list]\n* [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:FAQ MediaWiki FAQ]\n* [https://lists.wikimedia.org/mailman/listinfo/mediawiki-announce MediaWiki release mailing list]\n* [https://www.mediawiki.org/wiki/Special:MyLanguage/Localisation#Translation_resources Localise MediaWiki for your language]\n* [https://www.mediawiki.org/wiki/Special:MyLanguage/Manual:Combating_spam Learn how to combat spam on your wiki]"
314 }