bc5af86779e436ec0cd749213c092e87efaadfb2
[lhc/web/wiklou.git] / RELEASE-NOTES-1.29
1 == MediaWiki 1.29 ==
2
3 THIS IS NOT A RELEASE YET
4
5 MediaWiki 1.29 is an alpha-quality branch and is not recommended for use in
6 production.
7
8 === Configuration changes in 1.29 ===
9 * Default cookie expiration time has been reduced to 30 days. Login cookie
10 expiration time is kept at 180 days.
11 * A new configuration variable has been added: $wgCookieSetOnAutoblock. This
12 determines whether to set a cookie when a user is autoblocked. Doing so means
13 that a blocked user, even after logging out and moving to a new IP address,
14 will still be blocked.
15 * The resetpassword right and associated password reset capture feature has
16 been removed.
17 * The $error parameter to the EmailUser hook should be set to a Status object
18 or boolean false. This should be compatible with at least MediaWiki 1.23 if
19 not earlier. Returning a raw HTML string is now deprecated.
20 * The $message parameter to the ApiCheckCanExecute hook should be set to an
21 ApiMessage. This is compatible with MediaWiki 1.27 and later. Returning a
22 code for ApiBase::parseMsg() will no longer work.
23 * ApiBase::$messageMap is no longer public. Code attempting to access it will
24 result in a PHP fatal error.
25 * $wgUserEmailUseReplyTo is now true by default to work around restrictive DMARC
26 policies.
27 * Subpages are now enabled by default in the Template namespace. Set
28 $wgNamespacesWithSubpages[NS_TEMPLATE] to false to keep the old behavior.
29 * $wgRunJobsAsync is now false by default (T142751). This change only affects
30 wikis with $wgJobRunRate > 0.
31
32 === New features in 1.29 ===
33 * (T5233) A cookie can now be set when a user is autoblocked, to track that user
34 if they move to a new IP address. This is disabled by default.
35 * Added ILocalizedException interface to standardize the use of localized
36 exceptions, largely so the API can handle them more sensibly.
37 * Blocks created automatically by MediaWiki, such as for configured proxies or
38 dnsbls, are now indicated as such and use a new i18n message when displayed.
39 * Added new $wgHTTPImportTimeout setting. Sets timeout for
40 downloading the XML dump during a transwiki import in seconds.
41 * Parser limit report is now available in machine-readable format to JavaScript
42 via mw.config.get('wgPageParseReport').
43 * Added $wgSoftBlockRanges, to allow for automatically blocking anonymous edits
44 from certain IP ranges (e.g. private IPs).
45 * (T59603) Added new magic word {{PAGELANGUAGE}} which returns the language code
46 of the page being parsed.
47 * Added JavaScript that provides as-you-type suggestions for reason
48 on the block, delete and protect forms.
49 * HTML5 form validation attributes will no longer be suppressed. Originally
50 browsers had poor support for them, but modern browsers handle them fine.
51 This might affect some forms that used them and only worked because the
52 attributes were not actually being set.
53
54 === External library changes in 1.29 ===
55
56 ==== Upgraded external libraries ====
57 * Updated QUnit from v1.22.0 to v1.23.1.
58
59 ==== New external libraries ====
60
61 ==== Removed and replaced external libraries ====
62
63 === Bug fixes in 1.29 ===
64 * (T62604) Core parser functions returning a number now format the number according
65 to the page content language, not wiki content language.
66
67 === Action API changes in 1.29 ===
68 * Submitting sensitive authentication request parameters to action=clientlogin,
69 action=createaccount, action=linkaccount, and action=changeauthenticationdata
70 in the query string is now an error. They should be submitted in the POST
71 body instead.
72 * The capture option for action=resetpassword has been removed
73 * action=clearhasmsg now requires a POST.
74 * (T47843) API errors and warnings may be requested in non-English languages
75 using the new 'errorformat', 'errorlang', and 'errorsuselocal' parameters.
76 * API error codes may have changed. Most notably, errors from modules using
77 parameter prefixes (e.g. all query submodules) will no longer be prefixed.
78 * ApiPageSet-using modules will report the 'invalidreason' using the specified
79 'errorformat'.
80 * action=emailuser may return a "Warnings" status, and now returns 'warnings' and
81 'errors' subelements (as applicable) instead of 'message'.
82 * action=imagerotate returns an 'errors' subelement rather than 'errormessage'.
83 * action=move now reports errors when moving the talk page as an array under
84 key 'talkmove-errors', rather than using 'talkmove-error-code' and
85 'talkmove-error-info'. The format for subpage move errors has also changed.
86 * action=revisiondelete no longer includes a "rendered" property on warnings
87 and errors for each item. Use errorformat=wikitext if you're wanting parsed
88 output.
89 * action=rollback no longer returns a "messageHtml" property. Use
90 errorformat=html if you're wanting HTML formatting of error messages.
91 * action=upload now reports optional stash failures as an array under key
92 'stasherrors' rather than a 'stashfailed' text string.
93 * action=watch reports 'errors' and 'warnings' instead of a single 'error', and
94 no longer returns a 'message' on success.
95 * Added action=validatepassword to validate passwords for the account creation
96 and password change forms.
97
98 === Action API internal changes in 1.29 ===
99 * New methods were added to ApiBase to handle errors and warnings using i18n
100 keys. Methods for using hard-coded English messages were deprecated:
101 * ApiBase::dieUsage() was deprecated
102 * ApiBase::dieUsageMsg() was deprecated
103 * ApiBase::dieUsageMsgOrDebug() was deprecated
104 * ApiBase::getErrorFromStatus() was deprecated
105 * ApiBase::parseMsg() was deprecated
106 * ApiBase::setWarning() was deprecated
107 * ApiBase::$messageMap is no longer public. Code attempting to access it will
108 result in a PHP fatal error.
109 * The $message parameter to the ApiCheckCanExecute hook should be set to an
110 ApiMessage. This is compatible with MediaWiki 1.27 and later. Returning a
111 code for ApiBase::parseMsg() will no longer work.
112 * UsageException is deprecated in favor of ApiUsageException. For the time
113 being ApiUsageException is a subclass of UsageException to allow things that
114 catch only UsageException to still function properly.
115 * If, for some strange reason, code was using an ApiErrorFormatter instead of
116 ApiErrorFormatter_BackCompat, note that the result format has changed and
117 various methods now take a module path rather than a module name.
118 * ApiMessageTrait::getApiCode() now strips 'apierror-' and 'apiwarn-' prefixes
119 from the message key, and maps some message keys for backwards compatibility.
120
121 === Languages updated in 1.29 ===
122
123 MediaWiki supports over 350 languages. Many localisations are updated
124 regularly. Below only new and removed languages are listed, as well as
125 changes to languages because of Phabricator reports.
126
127 * Based as always on linguistic studies on intelligibility and language
128 knowledge by geography, language fallbacks have been expanded. When a
129 translation is missing in the user's preferred interface language, the
130 corresponding translation for the fallback language will be used instead.
131 English will only be used as last resort when there are no translations.
132 Some configurations (such as date formats and gender namespaces) have also
133 been updated when using the fallback language's configuration was inadequate.
134 The new or reinstated language fallbacks are (after cs ↔ sk in 1.28):
135 hsb ↔ dsb, io → eo, mdf → ru, pnt → el, roa-tara → it.
136
137 ==== No fallback for Ukrainian ====
138 * (T39314) The fallback from Ukrainian to Russian was removed. The Ukrainian
139 language will now use the default fallback language: English. When a translation
140 to Ukrainian is not available, an English string will be shown.
141
142 === Other changes in 1.29 ===
143 * Database::getSearchEngine() (deprecated in 1.28) was removed. Use
144 SearchEngineFactory::getSearchEngineClass() instead.
145 * $wgSessionsInMemcached (deprecated in 1.20) was removed. No replacement is
146 required as all sessions are stored in Object Cache now.
147 * MWHttpRequest::execute() should be considered to return a StatusValue; the
148 Status return type is deprecated.
149 * User::edits() (deprecated in 1.21) was removed.
150 * Xml::escapeJsString() (deprecated in 1.21) was removed.
151 * Article::getText() and Article::prepareTextForEdit() (deprecated in 1.21)
152 were removed.
153 * Article::getAutosummary() and WikiPage::getAutosummary() (deprecated in 1.21)
154 were removed.
155 * Hook ArticleViewCustom (deprecated in 1.21) was removed. Use ArticleContentViewCustom
156 instead.
157 * Hooks EditPageGetDiffText and ShowRawCssJs (deprecated in 1.21) were removed.
158 * Class RevisiondeleteAction (deprecated in 1.25) was removed.
159 * WikiPage::prepareTextForEdit() (deprecated in 1.21) was removed.
160 * WikiPage::getText() (deprecated in 1.21) was removed.
161 * Article::fetchContent() (deprecated in 1.21) was removed.
162 * User::getPassword() (deprecated in 1.27) was removed.
163 * User::getTemporaryPassword() (deprecated in 1.27) was removed.
164 * User::isPasswordReminderThrottled() (deprecated in 1.27) was removed.
165 * Class FSRepo (deprecated in 1.19) was removed.
166 * WebRequest::checkSessionCookie() (deprecated in 1.27) was removed. Use
167 \MediaWiki\Session\SessionManager::singleton()->getPersistedSessionId() instead.
168 * Class ImageGallery (deprecated in 1.22) was removed.
169 Use ImageGalleryBase::factory instead.
170 * Title::moveNoAuth() (deprecated in 1.25) was removed. Use MovePage class instead.
171 * Hook UnknownAction (deprecated in 1.19) was actually deprecated (it will now
172 emit warnings). Create a subclass of Action and add it to $wgActions instead.
173 * WikiRevision::getText() (deprecated since 1.21) is no longer marked deprecated.
174 * Linker::getInterwikiLinkAttributes() (deprecated since 1.25) was removed.
175 * Linker::getInternalLinkAttributes() (deprecated since 1.25) was removed.
176 * Linker::getInternalLinkAttributesObj() (deprecated since 1.25) was removed.
177 * Linker::getLinkAttributesInternal() (deprecated since 1.25) was removed.
178 * RedisConnectionPool::handleException (deprecated since 1.23) was removed.
179 * The static properties mw.Api.errors and mw.Api.warnings, containing incomplete
180 and outdated lists of errors/warnings returned by the API, are now deprecated.
181 * wiki.phtml entry point was removed. Refer to index.php instead. If you want "wiki.phtml"
182 URLs to continue to work, set up redirects. In Apache, this can be done by enabling
183 mod_rewrite and adding the following rules to your configuration:
184
185 RewriteEngine On
186 RewriteBase /
187 RewriteRule ^/w/wiki\.phtml$ /w/index.php [R=301,L]
188 * Hook ArticleAfterFetchContent (deprecated in 1.21) was removed.
189 Use ArticleAfterFetchContentObject instead.
190 * Hook ArticleInsertComplete (deprecated in 1.21) was removed.
191 Use PageContentInsertComplete instead.
192 * Hook ArticleSave (deprecated in 1.21) was removed.
193 Use PageContentSave instead.
194 * Hook ArticleSaveComplete (deprecated in 1.21) was removed.
195 Use PageContentSaveComplete instead.
196 * Hook EditFilterMerged (deprecated in 1.21) was removed.
197 Use EditFilterMergedContent instead.
198 * Hook EditPageGetPreviewText (deprecated in 1.21) was removed.
199 Use EditPageGetPreviewContent instead.
200 * Hook TitleIsCssOrJsPage (deprecated in 1.21) was removed.
201 Use ContentHandlerDefaultModelFor instead.
202 * Hook TitleIsWikitextPage (deprecated in 1.21) was removed.
203 Use ContentHandlerDefaultModelFor instead.
204 * Article::getContent() (deprecated in 1.21) was removed.
205 * Revision::getText() (deprecated in 1.21) was removed.
206
207 == Compatibility ==
208
209 MediaWiki 1.29 requires PHP 5.5.9 or later. There is experimental support for
210 HHVM 3.6.5 or later.
211
212 MySQL is the recommended DBMS. PostgreSQL or SQLite can also be used, but
213 support for them is somewhat less mature. There is experimental support for
214 Oracle and Microsoft SQL Server.
215
216 The supported versions are:
217
218 * MySQL 5.0.3 or later
219 * PostgreSQL 8.3 or later
220 * SQLite 3.3.7 or later
221 * Oracle 9.0.1 or later
222 * Microsoft SQL Server 2005 (9.00.1399)
223
224 == Upgrading ==
225
226 1.29 has several database changes since 1.28, and will not work without schema
227 updates. Note that due to changes to some very large tables like the revision
228 table, the schema update may take quite long (minutes on a medium sized site,
229 many hours on a large site).
230
231 If upgrading from before 1.11, and you are using a wiki as a commons
232 repository, make sure that it is updated as well. Otherwise, errors may arise
233 due to database schema changes.
234
235 If upgrading from before 1.7, you may want to run refreshLinks.php to ensure
236 new database fields are filled with data.
237
238 If you are upgrading from MediaWiki 1.4.x or earlier, you should upgrade to
239 1.5 first. The upgrade script maintenance/upgrade1_5.php has been removed
240 with MediaWiki 1.21.
241
242 Don't forget to always back up your database before upgrading!
243
244 See the file UPGRADE for more detailed upgrade instructions.
245
246 For notes on 1.28.x and older releases, see HISTORY.
247
248 == Online documentation ==
249
250 Documentation for both end-users and site administrators is available on
251 MediaWiki.org, and is covered under the GNU Free Documentation License (except
252 for pages that explicitly state that their contents are in the public domain):
253
254 https://www.mediawiki.org/wiki/Special:MyLanguage/Documentation
255
256 == Mailing list ==
257
258 A mailing list is available for MediaWiki user support and discussion:
259
260 https://lists.wikimedia.org/mailman/listinfo/mediawiki-l
261
262 A low-traffic announcements-only list is also available:
263
264 https://lists.wikimedia.org/mailman/listinfo/mediawiki-announce
265
266 It's highly recommended that you sign up for one of these lists if you're
267 going to run a public MediaWiki, so you can be notified of security fixes.
268
269 == IRC help ==
270
271 There's usually someone online in #mediawiki on irc.freenode.net.